*

Adobe Air3.4アップデート時の不具合と対処法

公開日: : ぱちぇコンウォーズ, 告知

8/22頃、Adobe AIRランタイムの最新バージョン(v3.4)がリリースされたそうなのですが、どうやらELSの読み込みの互換性が失われているという致命的な不具合があるようで、それ以前に「ぱちぇコンウォーズ」をインストールしているPCにて、AIR3.4へののアップデートを行うと、以下のようなエラー画面が出てゲームが起動できなくなってしまいます。

エラーデス!!画面

もし、AIR3.4へアップデートしてしまい、エラー画面が出て止まってしまった場合は、
1.Adobe AIRをv3.3へダウングレードする
2.頒布したCDに入っている「PatcheConWars_0.3.air」を実行して、再インストール、再アップデート
の、いずれかの方法にて、「ぱちぇコンウォーズ」をプレイできるようになります。

Adobe AIRのダウングレード方法は、
現在インストールされているAdobe AIRをアンインストールして、
下記のリンクよりAdobe AIR(v3.3)をインストールします。
 Windows用 - Adobe AIR 3.3.0.3670 Windows (14.5 MB)
 Mac用 - Adobe AIR 3.3.0.3670 Mac (23.4 MB)
その後、「Adobe AIRのアップデートをインストールする準備が整いました」と表示されますが、ここでは「後でアップデート」を選択してください。

上記の方法によって、「ぱちぇコンウォーズ」のセーブデータが消えるといった事は無いはずです。
(現状、キャンペーンのクリア状況くらいしかセーブデータは無いですが・・・)

ぱちぇコンウォーズの場合は、幸い再インストールさえすればAir3.4を問題なく使用可能ですが、他にAirランタイムを使用しているアプリ(主にTwitterクライアントやゲーム等、ユーザー情報をローカルに記録しているもの)でも、AIR3.4へのアップデート時の不具合が確認されているようなので、まだAIR3.4へのアップデートを行なっていない場合は、しばらくはAIR3.4へのアップデートはしない方が良いかもしれません。
Adobeの方も、未だにこの問題については「調査中」という段階らしいので…

参考元

http://fx.inet-sec.com/frontend/info/detail.do;jsessionid=0F4D863BFC20ECC3DD493BBD0AEFF644?id=1284
http://cuaoar.jp/2012/08/flash-player-114-adobe-a.html
http://forums.adobe.com/thread/1053337?start=0&amp%3Btstart=0#.UDYpZ5Fnka8.twitter

Message

メールアドレスが公開されることはありません。

PAGE TOP ↑